Netstream 4c. A different failure on each platform

Recommended Posts


I have a new netstream 4c in the UK

On Windows 10... the application starts and says my netstream device needs a firmware update.. that I can only do this on android or iOS.

The app then sits for about 2 minutes then fails and shuts down. Reinstall and rollback both fail to resolve. Installation on a different Windows 10 machine has the exact same result.


On android. Samsung s8. The app fails to find any devices


On android. Samsung s5 the app finds the device and advises that I run a channel scan.

The scan finds no channels.


On OSX eyetv says there are no geniatech netstream devices found


On iOS. My device is tool old to install from the app store....


I have installed the device direct to my internet router and also to a gigabit switch and run tests with the same result.


I have tried devices wifi and hard wired. Same results


So all in all an abject failure. I had purchased two for the office... and have cancelled the second. I just need to get the one already delivered to work...

This disappointing as I have had an eyetv hybrid on my Mac for over 10 years with nothing but great experience.

If I cannot get help here I will package up netstream and return as faulty.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.