Sign in to follow this  

Bugs with released EyeTV 4 Mac

Recommended Posts

So EyeTV 4 is here at last and on the whole is OK, whilst almost nowhere being as polished as its predecessor.

But there's no dedicated forum.

And no Bug Report forum.

So I have been putting in support requests when I spot a bug to which I have response whatsoever.

In the vain hope that someone from Geniatech is interested, here are the bugs I have found so far.....

1. The edit facility doesn't work properly. The cut into chunks and then shorten each chunk idea is not very intuitive and is slower than the double triangle system in EyeTV 3, but that's just an irritation not a bug. It is quite hard to get the red cursor to go to the section you want to cut. What is really serious is that if I shorten a recording and then select 'save clip as recording' it crashes instantly. Every recording is the same. And if you try to edit an audio only recording, say from the radio, it crashes instantly, before you have even made cuts. Making edits and them compacting does work, it is saving a chunk as its own recording which doesn't.

2. Every time the app restarts you get a live tv window, no matter how the preferences are set. This is an old bug from EyeTV 3 from the Elgato days which is now back in the new version.

3. The recordings window doesn't refresh when a new recording starts or finishes. You have to click the TV guide or channel list and then go back to the recordings window before you can see whether something is actually recording or not. Given that it doesn't always initialise and start, this is an irritating omission - it is handy to be able to see the new recording appear in the recordings and the seconds recorded indicator start to count up. In order to see the seconds count increase with a recording which has just started, you have to click on another main window icon and then back to the recordings window.

4. The Episode information in the recordings list doesn't show like it used to. So all examples of the same show appear to be the same, you can't see at a glance whether you've got the latest one or not. Not the end of the world, but it's annoying and unnecessary reduction in usability.


I'm sure other people have found other problems. If anyone from Geniatech is seeing this, how about actually giving users a way to work with you to sort the inevitable early glitches out quicker?

Share this post

Link to post
Share on other sites

I have tried versions 8518, 8519 and 8520 of EyeTV4 but all simply crash when clicking on record. I am trying to record from a composite input on a Hybrid TV stick on the latest Catalina. I've tried a clean install, but that makes no difference.

I am not sure this should have been a release, let alone that they're asking people pay for what seems to be a very buggy beta...

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this