Tutorial: How to update the Netstream 4C firmware and make it work with TVHeadend

Recommended Posts

DANGER! This precodure worked for me. I can't guarantee that this also works for you. You might brick your device.

Hey everyone,
I wasted the last 2 days but I found a way to update the firmware of my Netstream 4C from version 1.1.0-365r1 to version The FAQ and the articles on the Geniatech site are a lie. You can do it with MacOS, Windows or Linux but not with your smartphone (or maybe you can if you can find a super old version of the EyeTV netstream phone app but I don't have access to those)
You just need to find the right Eyetv3 version for MacOS and download it. You cannot update with EyeTV4. I found the firmware update only inside the MacOS versions of EyeTV3. I could not find any Windows installers for EyeTV3...maybe the firmware is also present in the Windows version.

Why do this?
I was having trouble getting the device to work with TVHeadend and Kodi, so I thought an update might help. Later I found out that I was lucky and with my original 1.1.0-365r1 firmware it actually works with TVHeadend, Kodi, EyeTV and the EyeTV Netstream App all at the same time without any modifications right out of the box.
I also saw that some of you don't get EyeTV4 to recognize the Netstream 4C so this might be worth a try.
Then a fow days later I found out how to make it work just as well with the firmware and TVHeadend...see bottom paragraph.


Step 1 - Downloading the right EyeTV3 version:
The firmware file is inside the EyeTV programm files...but only in specific versions. I found it in in versions:
- 3.6.8 (7407)
- 3.6.9 (7412, 7415, 7512, 7513 and 7514)

You can download one of them here:
If you want another version you can just change the last 4 numbers of the link. Send me a message and I'll send you a mirror link if this site ever goes down.

Step 2 - Extracting the firmware:

If you're on MacOS:
- mount the .dmg file
- then don't install it, just right click on the EyeTV icon and select "Show Package Contents"
- then go into the folders Contents -> Resources -> Firmware -> SATIP
- in this folder you can find the file "V1.update"
- copy this file onto your desktop

- install it and do the update from within EyeTV in the Preferences -> Devices -> Info Menu -> Update Firmware Button

On Windows:
- extract the .dmg with 7zip
- navigate to -> Contents -> Resources -> Firmware -> SATIP
- in this folder you can find the file "V1.update"
- copy this file onto your desktop

The checksums are:
MD5: d4268e5c3981fdca13d4d729735895fb
SHA256: 3005e7fdf3459e523b95d0e4c4c612f6cf4d5d5ea23f6bbacf1c6efafa1bf9bf

Step 3 - Intalling the firmware:
- find out what IPv4-adress your Netstream 4C has on you LAN-Network (look it up in the app or your router)
- for me it was (this is different for everyone!)
- type this address in your browser like this:
- on my firmware version there was just a button that opens a dialog where I select the firmware file and then press the "upload file" button

This step might be different depending on your current firmware version. Maybe you have to click somewhere else first to get to the firmware update menu. (might upload some screenshots later)

After you uploaded the firmware, the device will reboot and you can check the firmware version either in the Netstream app, EyeTV or if you log onto the device via ssh with "root" as username and "service" as password an then type "Tombea --version". The IP of the device might have changed, so don't panic if the site doesn't reload.

For me, if I now reset the device, it'll downgrade and go back to my original firmware. I don't know if this is the same for everyone. It might depend on what your original firmware is. To reset I switched the device off, held down the reset button while flipping the switch on again and then released it when both the orange and the blue led were both light up constantly.


some background and why I know all of this:

I was trying to find this out for days and could not find any guide on how to do this. In every thread nobody actually says how they did it. So I wanted to find it out. I installed VirtualBox and set up a MacOS Mojave VM on my Windows PC. I did it with this guide:

The download links are dead on the site above. I downloaded MacOS Mojave 10.14.3 HFS by Geekrar here

You also need to set your network adaptor to network bridge mode, otherwise you can't detect the Netstream 4C from inside the VM.

In the VM I installed one of the EyeTV3 versions metioned above and updated the Netstream from inside Eyetv while running Wireshark to scan my network traffic. I was surprised, that while updating there was no connection to an external server to download the firmware update. That's how I concluded that the firmware must be on my PC already. After some digging I found it in EyeTV's file folder.

In Wireshark I saw, that EyeTV on port 49803 send a HTTP POST on the /fwupload URI and then sent a file with 14339107 bytes via TCP to the IP of my Netstream 4C on port 80. The only file with this size on my PC is "V1.update", therefore it had to be the firmware of the Netstream 4C.

Also I think the 4C and the 4SAT share the same firmware update. On all versions of EyeTV there is never a folder explicitly for either the 4SAT or the 4C...only the folder SATIP. I think they have a different base firmware but the updates are the same. I can't confirm this since I don't have a 4SAT. Don't rely on my assumption.

I also think that this firmware update file is not the whole firmware. I'm not super deep into Linux but I think that this part of the firmware is just a programm on the device that just gets started after the update instead of the original firmware and the reset button just deletes this file and it then reboots again with the base firmware....that's my assumption. Otherwise if it was written to ROM you couldn't go back to the old firmware version.


making it work with TVHeadend on the new firmware:

I saw this thread on the TVHeadend forums and a person named Marti McFly describes how to make it work.



Since the Netstream 4C does not do service announcement by itself, you've got two options to make TVHeadend recognize it.

1. Pass the sat>ip description to tvheadend manually

--satip_xml http://IPADDRESSOFNETSTREAM:81/description.xml

2. Enable sat>ip service announcement on the Netstream 4C.

Connect to the Netstream 4C

#> ssh root@
password: service

Kill the streaming deamon, give it 30 seconds to finish and run it with ssdp (Simple Service Discovery Protocol) turned on. Please keep in mind, that the official IOS and Android apps won't find it with this option turned on.

#> killall Tombea
#> Tombea -i 1 --no-alternate-discovery

Once after you've made tvheadend find the device, it remembers the netstream 4Cs IP and you won't have to enable ssdp again.

Please find the tuner options in the attached screenshots.

Have fun!

They say that this way, the offical app won't find the device but in my experience, with android app version 2.1.43 it still recognizes the Netstream....But I guess if you want TVHeadend, you would use Kodi and not the official app.

I think this whole procedure is only useful for you, if you want to use EyeTV with your Netstream 4C and it currently does not find it with your older firmware version....or if you are on a firmware version, on which the device doesn't work with TVHeadend. So far I can't see any other if everything is working for you, just stay on your version.

Share this post

Link to post
Share on other sites

Finally! Thank you (and all the others who have worked and contributed tidbits of information on this elsewhere)!

I struggled with this a couple of years back and couldn't get TVHeadend to recognize my Netstream 4C even after resetting it to the initial firmware & toying with some of the Tombea options and eventually gave up until now after noticing the tutorial. By trial and error I had learned that at least one certain EyeTV3 version would upgrade the firmware back but your info about the exact versions is also appreciated.

At least for me, everything in the tutorial checked out and my Netstream 4C is now working with EyeTV3 running on Mac mini and TVHeadened from CoreELEC/Kodi. On the Mac mini I also use etv-comskip which luckily can be set to mark the commercial also for Kodi (set output_vdr=1 in comskip.ini) and if I remember correctly, this also worked fine when toying with a separate tuner earlier.

Once again big thanks!

Share this post

Link to post
Share on other sites


I have a problem integrating my netstream 4C to TVHeadend.

When I start the Tombea with " Tombea -i 1 --no-alternate-discovery" everything works fine.

After a restart of the netstream and also TVH there is no TV adapter visible anymore even when I start TVH with the satip_xml parameter pointing on the netstream.

But this is more a question for the TVH forum where I already posted.

It seems that my firmware version is different to yours?! Not quite sure, but you wrote " "

while mine is

[ARCLinux]$ Tombea --version
Elgato DVB>IP Server 1.1.0-402r1, Feb 19 2015, 17:49:21
Compiled for ViXS ARC700 platform, XCode Version 4A5546
Copyright (C) 2013-2014 Elgato Systems GmbH, Germany


Is this really a differnt version to yours??


Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.