EyeTV 4 & Netstream Sat

Recommended Posts

** Apologies for posting this here as well as in the EyeTV software forum. I wasn't sure where this should go. Mods: Please delete one of the posts if necessary. Thanks! **


Last year, I purchased a second-hand Elgato EyeTV Netstream Sat on a bit of a whim. My satellite receive isn't really in the most useful room of the house anymore and it seemed like it would be a good idea to replace this with a network tuner so that I could watch TV elsewhere. I'm using the satellite system for free-to-air service from Astra 19.2E, and the dish and receive are both working well.

I haven't had the chance to do anything with it until now, but with the internet under strain due to the Coronavirus, I thought I'd do my bit and reduce my use of streaming radio and TV services and get everything set-up. I'm having problems getting it to work though, and I wondered if anyone might able to point me in the right direction.

Although the seller supplied the box and the original CD, they didn't include a licence key for EyeTV 3. I'm still using macOS 10.14 at the moment but I suspect I'll need to go '64-bit' only sooner or later, so I purchased a licence for Eye TV 4 directly from Geniatech.

I've connected everything, installed the software and run the Setup Assistant, but keep getting a told "No devices found" after selecting "Netstream" from the list of options available. I've tried selecting the Netstream from both the 'Geniatech' and 'Network / IPTV' lists, but neither seems to work.

I tried resetting the Netstream itself by powering on the unit whilst holding down the reset button on the back. It's now displaying an orange light rather than a green one, but my router can still see it and has given it an IP address.

Would anyone have any ideas as to what to try next? Is this hardware compatible with version 4 of EyeTV, or have I bought the wrong version of the software? Have I somehow not reset it properly, and left it in a sort of limbo state?

I'd be very grateful for any help and suggestions; thanks in advance!

I hope everyone is keeping safe and well.




Share this post

Link to post
Share on other sites

I have this combination, apart from I'm running Big Sur on an M1 air. Eyetv 4 is seeing my device fine. So if you browse to the Ip address the Elgato is on you see the web interface?


Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.