JuHa

No firmware update

Recommended Posts

Last week I bought a new Netstream 4c from the Geniatech shop. Installation runs easy but I didn't receive a firmware update. My Netstream reported 

EyeTV Netstream 4C
Serial: 3167
Version: 1.1.0-390r1

The Netstream also disconnected after 30 min from EyeTV - after restarting EyeTV the Netstream was reconnected.

My setup: 

  • MacMini (End 2014)
  • HighSierra 10.13.1
  • Fritz!Box 7430 - cat6 cables
  • EyeTV 3.6.9 (7520) - same behavior with 7521 or 7522  

Any ideas?

Share this post


Link to post
Share on other sites

Have the same problem. My Firmware is on 1.1.0-390r1.

Neither eyeTV on a mac or iPhone show me an option to upgrade the firmware.

I tried on Windows and THC said my Firmware is "too old", I should update.

I can't find online which the newest firmware is. Is there any?

Share this post


Link to post
Share on other sites

I tried to email Geniatech support in German and English, tried their hotline. - Nothing. Geniatech support is the worst experience I had with a company since ages. Nobody can tell me how to update from this super old firmware.

I wish there was another option on a mac than EyeTV. Hardware barely works, software is not (really) updated since over 10 years. Airplay? No. Fullscreen (OSX)? No. Modern interface? No. Apple TV software is a joke. iOS is crashing a lot. Android software is... how should I know? :)

And I am so stupid and keep buying that stuff. Horrible! :( 

EyeTV 4C.jpg

Share this post


Link to post
Share on other sites

@eyekey " wish there was another option on a mac than EyeTV."

You could switch to DVBlink (works out of the box. check dvblogic.com) or if you love tinkering then MythTV or TVHeadend (if you own a NAS) are alternatives. DVBlink does almost everything EyeTV does but with good support. Pity is that their scheduling options are rudimentary.

 

Share this post


Link to post
Share on other sites
22 hours ago, Ton said:

You could switch to DVBlink

Does not work in Germany. And it sticks into a single computer via USB.

I used HDHomerun (European version) since a few years. It worked flawlessly. EyeTV dropped support, so I bought a Netstream 4C. Sadly it is buggier than a third party device. The TV-window closes every now and then. It is so sad, they cannot even maintain their own hardware well.

BTW... I asked on Amazon which is the newest firmware. For Netstream 4C it is 1.1.0.402r1-V1. The question is, how to get my device updated to that? Mac, iOS and Android are not showing a button to update. And Geniatech is bungling.

Share this post


Link to post
Share on other sites

I bought a Netstream 4c on friday from Amazon. I was hoping to get things sorted out, but i also coulnd't update the firmware and the Apple TV app is a joke, indeed.

So i will send it back today. My next attempt will be a VU+ box (or another linux tv streaming set top box) with about two cable tuners and the vuplusTV app for Apple TV:

vuplusTV app:

https://itunes.apple.com/de/app/vuplustv/id1068958397?mt=8

thread:

https://www.vuplus-support.org/wbb4/index.php?thread/90469-tvos-vu-tv-app-appletv-support-thread/&pageNo=42&s=67a6fd1bc983a504ddb993bbecdceacce8e889a1

k

Share this post


Link to post
Share on other sites
13 hours ago, krlklm said:

My next attempt will be a VU+ box (or another linux tv streaming set top box) with about two cable tuners and the vuplusTV app for Apple TV:

Looks amazing!

Please give feedback after you set it up. Software looks very modern (unlike EyeTV which is still in 2005). But there is not a MacOS app, or am I wrong?

Are you in Germany, too?

Share this post


Link to post
Share on other sites

yes, frankfurt. I'm not sure when i will find the time to make the research on which of those linux set top boxes to get, but hopefully I don't forget to make a post over here when its done.

I'm not aware of a macOS app for this setup, no.

Edited by krlklm

Share this post


Link to post
Share on other sites

After going back from the latest version of EyeTV to version 7412, I was able to update the firmware to 1.1.0.402r1-V1. The option just came up in the setting menu.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now